This tracker is in read-only mode.
Please report all Sanny Builder issues on GitHub.


View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000063Sanny Builder[All Projects] compilerpublic2020-08-06 03:192020-08-19 02:14
ReporterMarcelo20XX 
Assigned ToSeemann 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindowsOS Version7
Product Version 
Target VersionFixed in Version3.4.1 
Summary0000063: Cant compile MAIN.SCM of Vice City Stories
DescriptionI tried to recompile the MAIN.SCM from Vice City Stories now that SannyBuilder 3.4.0 have support for it but I receive an error on two lines:

:DIA_C5_9085
0078: if and
0045: actor 0@ defined
004F: $5373 unknown_check
0022: jump_if_false @DIA_C5_9141 //there is no such label
02EE: get_actor 0@ coords_to 2@ 3@ 4@ with_offset 0 1@ 0.8
004D: store_car $5373 position_to 5@ 6@ 7@
04E3: (unknown) 18 2@ 3@ 4@ 5@ 6@ 7@ 0.35
010D: put_object 8@ at 25@ //incorrect number of parameters expected 4

I tried to re-compile without any changes and couldn't because those two errors pop-up, deleted those lines made the program compile the file but I dont know if it is safe or will hung up when running that code
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000072)
Seemann (administrator)
2020-08-06 16:55

hey Marcelo, thanks for reporting that! Please check the new 3.4.1 version and let me know if the issue still exists.

Also if you can test SCM changes on the real game please tell me if that works

- Issue History
Date Modified Username Field Change
2020-08-06 03:19 Marcelo20XX New Issue
2020-08-06 03:19 Marcelo20XX Status new => assigned
2020-08-06 03:19 Marcelo20XX Assigned To => Seemann
2020-08-06 16:55 Seemann Note Added: 0000072
2020-08-06 16:55 Seemann Status assigned => resolved
2020-08-06 16:55 Seemann Resolution open => fixed
2020-08-19 02:13 Seemann Status resolved => closed
2020-08-19 02:13 Seemann Fixed in Version => 3.5.0
2020-08-19 02:13 Seemann Status closed => resolved
2020-08-19 02:14 Seemann Fixed in Version 3.5.0 => 3.4.1


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker