View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000030Sanny Builder[All Projects] compilerpublic2014-08-10 17:362015-09-28 14:44
ReporterEmissary 
Assigned ToSeemann 
PriorityimmediateSeveritymajorReproducibilityalways
StatusfeedbackResolutionreopened 
PlatformOSWindows 7 SP1 ultimate x64OS Version6.1.7601.22616
Product Version3.2.2 
Target VersionFixed in Version 
Summary0000030: Does not compile file "main.scm"
DescriptionWhen I try to compile, it displays an error "Неверное число условий." on line 232224. Happens on version 3.2.1. Version 3.1.4 compiles without problems.
TagsNo tags attached.
Attached Filespng file icon Сохраненное изображение 2014-8-10_16-28-41.204.png [^] (16,517 bytes) 2014-08-10 17:36

- Relationships
has duplicate 0000029closedSeemann Does not compile file "main.scm" 

-  Notes
(0000029)
Seemann (administrator)
2014-08-11 11:42

Look, it's not a bug. Your IF statement have no any conditions to check, thus the compiler consider this as a possible mistake on your side. To avoid this message, either:
1) turn off the "Check conditions" check in the Sanny options (F10).
2) remove the 'if' and 'else_jump' opcodes from that piece of the code (they actually do nothing).
3) add some dummy conditional opcode in between the 'if' and 'else_jump' opcodes, so there is at least one condition to check.
(0000030)
Emissary (reporter)
2014-08-14 22:30

Nothing helped.

http://www.screencapture.ru/uploaded/91/b2/23/91b22362.jpg [^]
(0000031)
Seemann (administrator)
2014-08-14 23:06
edited on: 2015-09-28 14:44

Current solution is to remove this code

if
else_jump @SYND4_3672
wait 0
jump @SYND4_3650

it won't cause any problems


- Issue History
Date Modified Username Field Change
2014-08-10 17:36 Emissary New Issue
2014-08-10 17:36 Emissary Status new => assigned
2014-08-10 17:36 Emissary Assigned To => Seemann
2014-08-10 17:36 Emissary File Added: Сохраненное изображение 2014-8-10_16-28-41.204.png
2014-08-11 11:42 Seemann Note Added: 0000029
2014-08-11 11:43 Seemann Status assigned => closed
2014-08-11 11:43 Seemann Resolution open => no change required
2014-08-11 11:45 Seemann Relationship added has duplicate 0000029
2014-08-14 22:30 Emissary Note Added: 0000030
2014-08-14 22:30 Emissary Status closed => feedback
2014-08-14 22:30 Emissary Resolution no change required => reopened
2014-08-14 23:06 Seemann Note Added: 0000031
2015-09-28 14:44 Seemann Note Edited: 0000031 View Revisions


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker